L'API Renault ne marche plus [Résolu]

3 participants

Aller en bas

L'API Renault ne marche plus [Résolu] Empty L'API Renault ne marche plus [Résolu]

Message par umberto Mar 28 Jan 2020 - 19:57

Bonjour,

j'ai utilisée l'API pour gagner quelque info de ma Zozo.

Ca commence via services-renault-ze.com
Code:

curl -o token.txt -H "Content-Type: application/json" -d'{"username":"zoe@GGGGG","password":"GGGGGG"}' https://www.services.renault-ze.com/api/user/login  


Depuis cette nuit ca ne retourne plus de token mais:
Code:
{"code":403900,"message":"com.worldline.renault.myzeonline.user.exception.RestrictedCountryException","timestamp":1580237124646,"redirectURLs":{"appstore":"https://myr.renault.de/ze-redirection.html?os=ios","playstore":"https://myr.renault.de/ze-redirection.html?os=android","website":"https://myr.renault.de/ze-redirection.html?os=web"},"locale":"de_DE"}

RestrictedCountryException...dz.. :-)

Est-ce qu'il y a quelqu'n qui sait le nouveau adress de l'API?

Merci.
umberto
umberto

Messages : 211
Date d'inscription : 18/08/2012
Localisation : Allemagne

Revenir en haut Aller en bas

L'API Renault ne marche plus [Résolu] Empty Re: L'API Renault ne marche plus [Résolu]

Message par umberto Mar 28 Jan 2020 - 20:20

Tout est écrit ici :

https://github.com/jamesremuscat/pyze

Quelle malheur...c'est beaucoup plus difficile de gagner les infos....
umberto
umberto

Messages : 211
Date d'inscription : 18/08/2012
Localisation : Allemagne

Revenir en haut Aller en bas

L'API Renault ne marche plus [Résolu] Empty Re: L'API Renault ne marche plus [Résolu]

Message par seb.maccagnoni Mer 29 Jan 2020 - 13:33

Bah il y a une bibliothèque toute faite, du coup c'est plus facile...

seb.maccagnoni

Messages : 3815
Date d'inscription : 04/11/2014
Age : 39
Localisation : Colmar

https://www.maccagnoni.eu

Revenir en haut Aller en bas

L'API Renault ne marche plus [Résolu] Empty Re: L'API Renault ne marche plus [Résolu]

Message par umberto Mer 29 Jan 2020 - 23:22

@seb.maccagnoni a écrit:Bah il y a une bibliothèque toute faite, du coup c'est plus facile...

Oui et non. Je n'aime pas les bibliothèques complexes. Trop de possibilités de faire des fautes ou poser des problèmes de sécurité. La vielle API était très simple.
umberto
umberto

Messages : 211
Date d'inscription : 18/08/2012
Localisation : Allemagne

Revenir en haut Aller en bas

L'API Renault ne marche plus [Résolu] Empty Re: L'API Renault ne marche plus [Résolu]

Message par seb.maccagnoni Jeu 30 Jan 2020 - 8:12

Trop de possibilités de faire des fautes
Quel type de fautes ?
Le code est publiquement disponible, lisible par plusieurs personnes et améliorable vu que c'est de l'open source. Donc plusieurs cerveaux plutôt qu'un seul, donc a priori moins de possibilité de faire des fautes (et plus de possibilités de ne pas en faire, surtout).
poser des problèmes de sécurité
En quoi ?

... d'autant plus qu'elle n'est pas complexe, son code source est clair et court...

seb.maccagnoni

Messages : 3815
Date d'inscription : 04/11/2014
Age : 39
Localisation : Colmar

https://www.maccagnoni.eu

Revenir en haut Aller en bas

L'API Renault ne marche plus [Résolu] Empty Re: L'API Renault ne marche plus [Résolu]

Message par Feneck91 Jeu 30 Jan 2020 - 10:22

Ah ah .... seb.maccagnoni est sur les dents... On attend, on croise les doigts, on espère une nouvelle version de sa superbe application qui est morte.

_________________
Membre de l'ACOZE, "Association des COnducteurs d'automobiles Zéro Emission"
Propriétaire d'un grand Scenic IV diesel 1.6 dCI 130 et d'un Zoé Zen Q210 d'occasion (09/2014) livrée le 31/07/2017 + Upgrade 41kWh le 28/02/2019.
Feneck91
Feneck91
Administrateur

Messages : 5530
Date d'inscription : 29/07/2015
Age : 50
Localisation : Essonne (91)

Revenir en haut Aller en bas

L'API Renault ne marche plus [Résolu] Empty Re: L'API Renault ne marche plus [Résolu]

Message par seb.maccagnoni Jeu 30 Jan 2020 - 10:42

Houla, tu parles du machin que j'avais bricolé à l'époque où j'avais une ZOE ? Aucune chance pour que j'y touche à nouveau, désolé Smile

seb.maccagnoni

Messages : 3815
Date d'inscription : 04/11/2014
Age : 39
Localisation : Colmar

https://www.maccagnoni.eu

Revenir en haut Aller en bas

L'API Renault ne marche plus [Résolu] Empty Re: L'API Renault ne marche plus [Résolu]

Message par Feneck91 Jeu 30 Jan 2020 - 10:48

Ah non, je me suis gouré de personne !
C'est @lormar71 avec Application myzev.info, alternative enrichie à ZE Services

_________________
Membre de l'ACOZE, "Association des COnducteurs d'automobiles Zéro Emission"
Propriétaire d'un grand Scenic IV diesel 1.6 dCI 130 et d'un Zoé Zen Q210 d'occasion (09/2014) livrée le 31/07/2017 + Upgrade 41kWh le 28/02/2019.
Feneck91
Feneck91
Administrateur

Messages : 5530
Date d'inscription : 29/07/2015
Age : 50
Localisation : Essonne (91)

Revenir en haut Aller en bas

L'API Renault ne marche plus [Résolu] Empty Re: L'API Renault ne marche plus [Résolu]

Message par umberto Ven 31 Jan 2020 - 21:34

Erreur


Dernière édition par umberto le Ven 31 Jan 2020 - 21:39, édité 1 fois
umberto
umberto

Messages : 211
Date d'inscription : 18/08/2012
Localisation : Allemagne

Revenir en haut Aller en bas

L'API Renault ne marche plus [Résolu] Empty Re: L'API Renault ne marche plus [Résolu]

Message par umberto Ven 31 Jan 2020 - 21:38

@seb.maccagnoni a écrit:

... d'autant plus qu'elle n'est pas complexe, son code source est clair et court...

Nous nous ne trouvons pas ici, je pense. Le vieille API c'etait deux http-actions et 100 octets echangés. Maintenant on a besoin de deux token, beaucoup de python, produit plus de trafic et plus et plus.Pour ma c'est une malheur.

umberto
umberto

Messages : 211
Date d'inscription : 18/08/2012
Localisation : Allemagne

Revenir en haut Aller en bas

L'API Renault ne marche plus [Résolu] Empty Re: L'API Renault ne marche plus [Résolu]

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum